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LESSON PLAN

FCS Express High-Dimensional Data 
Reduction Tools Demonstration
Length: Approximately 75 minutes

 
Goal To demonstrate high-dimensional data reduction tools in FCS Express™

Objectives By the end of this module, participants will be able to:
• Perform tSNE analysis and utilize tools to visualize tSNE plots in FCS Express.
• Perform FlowSOM and utilize tools to visualize FlowSOM plots in FCS Express.

Materials • Computer
• Data files acquired on day 3 of training or any other sample data files 

Prior to the Lesson If you are not using the data from day 3 of training, identify a dataset to use  
for the demo. 

Introduction

There are many different platforms that one can use to analyze mass cytometry data. We support FCS 
Express, a fully featured flow cytometry data analysis package that has been designed to work seamlessly 
with mass cytometry data. New Helios™ and CyTOF® XT instruments and Hyperion™ Imaging Systems will 
include a one-year license of FCS Express Flow software. 

Performing high-dimensional data reduction is a quick and easy process with algorithms built directly into 
FCS Express. There is no need to rely on R or other outside software packages to perform dimensionality 
reduction. In the following primer you will learn how to set up, visualize, and prepare results for interpretation 
of the t-distributed stochastic neighbor embedding (tSNE) algorithms using the user interface in FCS Express. 
You will also be guided through preparation of data and charts using the FlowSOM (Self-Organizing Map) 
algorithm via FCS Express “pipeline” steps.

TM
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Performing tSNE Using FCS Express

The steps to perform and interpret tSNE are explained in the section below. Briefly, the analysis workflow 
consists of merging/grouping all the data files to be examined in the experiment, selecting variables for the 
tSNE algorithm, running the algorithm, using plot visualizations to deconvolve/ungroup the individual data 
files, and using additional plots for visualization/interpretation. The following steps guide you through these 
processes in FCS Express.

Merge Data Files for Preparation of tSNE Run

4	� Insert a plot of the virtual merged data file by 
dragging and dropping it from the Data List to a 
blank spot or new page of the layout (A), choose 
Density from the Plot Selection dialog (B), and 
click OK to insert the plot (C). 

Demonstration

NOTE: A copy of FCS Express Flow is distributed with new Helios, CyTOF XT™ and Hyperion Imaging System 
instruments. You can claim your free copy of FCS Express via the license packet that was provided with 
the instrument. Additional licenses, support, and free training can be requested through De Novo Software™ 
any time at support@denovosoftware.com. Alternatively, you can download a one-month free trial from 
https://denovosoftware.com/demo-overview/. 

NOTE: This is a brief overview. You can find additional online tutorials, short videos, and other resources at 
denovosoftware.com/full-access/. 

1	 Open a new or existing FCS Express layout. 

	 �EXAMPLE: Use the 7C_human_kit_analysis_
template.fey layout and accompanying example 
data files within the zip folder. Alternatively, use 
your own layout and data files. 

2	� Select the Data tab → Data List, and then click the 
blue plus  (A) to Select data file. 

3	� Click Options (B) to Merge FCS Files (*.fcs, *lmd, 
*.*) (C), browse to select the data files to merge, 
and click Open (D).

	� The files selected are merged into one .fcs file in 
the Data List for the tSNE run.

mailto:support%40denovosoftware.com?subject=
https://denovosoftware.com/demo-overview/
http://denovosoftware.com/full-access/
https://fcsexpressdownloads.s3.us-east-1.amazonaws.com/PublishedLayouts/7C_human_kit_analysis_template_and_data_files_HD.zip
https://fcsexpressdownloads.s3.us-east-1.amazonaws.com/PublishedLayouts/7C_human_kit_analysis_template_and_data_files_HD.zip
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Choose Variables and Define the tSNE Settings

NOTE: The FCS Express manual contains additional details on all available options and variables for the 
tSNE Run Options. 

2	� From Run Options, uncheck Automatically 
Calculate tSNE.

3	� From Gate dropdown menu in the Gate Options 
section, choose a high-level gate that includes all 
your subsets of interest but excludes events such 
as debris, doublets, contaminating cells, etc. The 
tSNE transformation will be calculated only on 
these cells. 

	 �EXAMPLE: In the provided 7C_human_kit_
analysis_template.fey with its example data files, 
choose CD45+. Your choice will depend on your 
experimental goal.

4	� Check that the merged file (PBMC sample 1.fcs – 
PBMC sample 4.fcs (4) Files) is set as the template 
file for the tSNE calculation in the Template File 
field found in the Parameter Options section. 
If not, click on the plot inserted in Step 4 in 
the Merge Data Files for Preparation of tSNE 
Run section. Choose Select Template From 
Selected Plot.

 

	� The Template File provides for the selection of 
raw data parameters associated with the file(s) for 
tSNE analysis. 

	 �EXAMPLE: If you are using the 7C_human_kit_
analysis_template.fey layout and its associated 
example data files, the template file will be 
automatically filled with the data currently loaded 
in the layout. 

5	� From Parameter Options, check the box beside 
the parameters on which the tSNE transformation 
will be calculated from the list box at left. Enter CD 
into the Filter field (A) to narrow down the list, and 
choose the parameters of interest (B).

	 �EXAMPLE: Select all the CD parameters (CD20, 
CD45, CD14, CD16, CD8, CD3, and CD4). 

1	� Select the Tools tab, then select Transformations 
(A). Click the blue plus  and then choose tSNE 
(B) from the dropdown menu. 

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?defining_a_tsne_transformation.htm#optsne
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Run the tSNE Algorithm 

1	� Drag and drop the New TSNE transformation 
(A) from the upper pane of the Transformations 
window to the plot inserted in Step 4 of the Merge 
Data Files for Preparation of tSNE Run section. 
The plot title is subsequently appended with the 
text tSNE mapped.

2	� Change the plot X- and Y- axes to tSNE X and 
tSNE Y (B), respectively.

	 �NOTE: The tSNE plot will not yet contain data 
because the tSNE transformation has not yet 
been calculated.

3	� From Run Options, click the Calculate tSNE 
button. The plot to which the tSNE Transformation 
was applied will be populated when the 
calculation is complete.

	� EXAMPLE: The results from the example data 
files, calculated on a Sample Size setting of 
30,000, are shown. 

	� NOTE: While the algorithm is running, FCS 
Express will be unresponsive. When the tSNE 
calculation is complete, the tSNE X vs. tSNE Y plot 
will be populated automatically with data.

6	� Enter the Sample Size in the Sampling Options 
section. 

	 EXAMPLE: Enter 30000. 

	� NOTE: If you wish to change additional 
downsampling and transformation options, you 
may do so in the Sampling Options section of 
the tSNE transformation dialog. See the FCS 
Express manual for more details on all of the 
Sampling Option variables settings and different 
downsampling options. 

	� FCS Express has the ability to use Opt-SNE and 
the unique ability to upsample/Estimate tSNE 
for Unsampled Events for events that were not 
included in the tSNE run because of either gating 
or downsampling. Many of the default settings in 
this primer are chosen to allow for a faster tSNE 
run while you learn how to use the basics of the 
interface. See tSNE performance in FCS Express 
to get a better idea of how your data size and 
computer will impact tSNE run times. 

	� The chosen parameters for the algorithm are 
up to the user to define and depend on the 
experimental goals and desired results. 

 

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?defining_a_tsne_transformation.htm#optsne
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/sampling_options.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?tsne_performance_in_fcs_expres.htm
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Deconvolution/Ungrouping Individual Data Files 

�After performing tSNE on a merged sample you will likely wish to view the results of each component file. You 
may also want to group component files from within the merged file for final analysis. In the next steps we will 
automatically create gates on each of the component files of the merged file to facilitate deconvolution. If you 
only wish to view the results on the merged file, proceed to Step 7.

2	� On the Gating tab, select Well (A). Then (B) click 
and drag your mouse cursor to encompass all the 
wells on your Plate Heat Map, which was created 
in the previous step.

3	� Enter auto in the Create a new gate named 
field (C).

4	� Select the gate on which the tSNE was 
calculated (D) (specified in Step 3 of the Choose 
Variables and Define the tSNE Settings; for the 
example choose CD45+) from the Parent Gate 
dropdown menu.

5	� Select the Create individual gates for each file 
indentifier checkbox (E). 

6	� Choose black from the Gate color dropdown 
menu and click OK (F).

7	� To visualize the results of the tSNE calculation on 
many parameters at once: 

	 a	� Click the tSNE plot to select it (A), click the 
Legend on the Format tab (B), check the 
Visible box (C), and choose Bottom from the 
Position dropdown menu (D). 

	 b	� Choose Title from the dropdown menu (A), 
delete existing text or tokens in the Title 
Options text field (B). Then choose Current 
Gate from the Insert Token menu (C). The 
gate applied to the plot will now appear in the 
plot title. 

1	� On the Insert tab, select Heat Map. Then select 
Plate Heat Map from the dropdown menus and 
click once on an empty spot on the layout to 
create the Plate Heat Map plot.
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8	� To view the results from the individual component 
files, select the tSNE multiplot array/group and 
its parent plot by clicking on the layout page 
(outside of any plots, so no objects are selected), 
and press Cmd[mac]-/Ctrl[PC]-A to select all. Then 
from the Gating tab, select Current Gate from 
the dropdown menu. Choose the automatically 
created gate that corresponds to the original 
component data file of interest. 

	� The multiplot array/group and its parent plot are 
regated to show only the events corresponding 
to the specified original data file. Repeat as 
needed for the other component files.

9	� (Optional) To view the results from the individual 
component files on separate layout pages, 
select, copy, and paste the multiplot array/
group and its parent plot to a new page in the 
layout. Then from the Gating tab, select Current 
Gate from the dropdown menu, and choose the 
automatically created gate that corresponds to 
the original component data file of interest. 

10	� To evaluate expression across the tSNE 
continents via Histogram Parameter Overlays: 

	 a	� On the Insert tab, select Histogram button. 
Then click once on a blank spot of the layout 
(or a new page) to insert the plot.

	 c	� Click the Plot tab family, then select Multi 
Plot tab and click the Color by All Parameters 
button (A). Right-click in the window to Clear 
Selection (B), enter CD in the Filter: field to 
narrow down the list (C), and check the CD 
parameters that are of interest regarding the 
tSNE analysis (D). Then click OK.

	 �	� EXAMPLE: Choose all the CD parameters 
(CD20, CD45, CD14, CD16, CD8, CD3, 
and CD4).

	 d	� Drag your mouse cursor around the group of 
plots created in the previous step to select 
them and resize, if desired. Repeat Step 7a to 
add a Legend. 

		�  The Multi Plot array will now show descriptive 
Legends, where each plot displays the intensity 
of expression of the indicated parameter.

	�	�  NOTE: You may reduce plot resolution via 
Specific Options if the plot colors are faint 
due to having only few events to visualize. For 
example, if you completed Steps 1–7 and/or 
tSNE was calculated on a small sample size 
(i.e., extensively downsampled). 

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?selecting_multiple_objects.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?copying_objects.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?pasting_objects.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?inserting_and_deleting_pages_f.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?specific_options.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?specific_options.htm
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	 b	� On the Gating tab, select a gate of interest 
from the Current Gate dropdown menu (A). 
Then change the parameter X-axis parameter 
to a parameter of interest (B). 

	�	�  EXAMPLE: Choose the gate on which the 
tSNE was calculated, CD45+. Then select 
147Sm_CD20.

	 c	� Right-click on the plot and choose Add 
Parameter Overlays from the pop-up menu 
(A). Then select additional parameters of 
interest (B). Check the Switch to stacked (C) 
and Use axis title from base overlay (D) boxes. 
Click OK (E).

	 �	� EXAMPLE: Select all the CD parameters 
including CD20, CD45, CD14, CD16, CD8, CD3, 
and CD4 from the Available Parameters list. 

	 d	� Repeat Step 7a to add a Legend on the right 
side of the plot. 

	 e	� Expand the width and height of the plot to 
better visualize the data. 

	 f	� (Optional) To access the histogram overlay 
property formatting options, select Overlays 
on the Format tab to adjust fill, transparency, 
line thickness, smoothing, and other 
formatting options. 

		  �EXAMPLE: For the data used in this primer 
we recommend a smoothing of 10 and using 
transparency fill set to 50. 

11	�Create a gate on the tSNE plot and apply it to the 
histogram parameter overlay plot to interrogate 
expression among the tSNE islands.

	 a	� On the Gating tab, select Polygon (A) and 
draw a gate on one of the tSNE islands within 
the parent plot shown in Step 7, which shows 
the virtual merged data file (B). Then enter 
Island Gate (C) and click OK (D).

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?overlays.htm
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	� The files selected will be merged into one .fcs file 
in the Data List for the FlowSOM run.

3	� Drag and drop a data file from the Data List to 
a blank spot on the layout or to a new page (A) 
to insert a plot of the virtual merged data file. 
Choose Plate Heat Map (B). Click OK (C). 

	 b	� Click on the histogram parameter overlays 
plots shown in Step 10f to select it. On the 
Gating tab, select Island Gate from the 
Current Gate dropdown menu. 

		�  The plot has now been regated to show only 
events within the island gate. You may resize or 
reposition the island gate. Notice the change 
in the histogram parameter overlay plot to 
evaluate expression of different populations or 
islands within the tSNE plot.

Performing FlowSOM Using FCS Express

FlowSOM is a transformation that employs Self-Organizing Map clustering and Minimal Spanning Trees. These 
steps are followed by a Consensus Clustering step in which metaclusters are identified. Briefly, the steps in 
a FlowSOM analysis are to merge the data files from your experiment, choose variables for the FlowSOM 
algorithm, run the algorithm, use plot visualizations to deconvolve/ungroup the individual data files, and use 
additional plots to examine the results at the metacluster level. The following procedure guides you through 
this workflow in FCS Express.

Merging Data Files for Preparation of FlowSOM

�NOTE: If you have already completed the previous 
section (Performing tSNE Using FCS Express), 
proceed to Step 3.

1	 Open a new or existing FCS Express layout. 

	� EXAMPLE: Use the 7C_human_kit_analysis_
template.fey layout and accompanying example 
data files within the zip file. However, you may use 
any layout and data files.

2	� To create a merged data file select Data List from 
the Data tab. Then click the blue plus  to Select 
data file (a). Select Options (b) to Merge FCS Files 
(*.fcs, *lmd, *.*) (c). Browse to select data files to 
merge (d). Click Open (e). 

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?inserting_and_deleting_pages_f.htm
https://fcsexpressdownloads.s3.amazonaws.com/7C_human_kit_analysis_template_and_data_files_HD.zip
https://fcsexpressdownloads.s3.amazonaws.com/7C_human_kit_analysis_template_and_data_files_HD.zip
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Choosing Variables and Defining the FlowSOM Settings 

2	� Uncheck Automatically Run Pipeline from 
Run Options. 

	� �In the Gate Options section, choose a high-level 
gate that includes all your subsets of interest but 
excludes events such as debris, doublets, and 
contaminating cells from the Gate dropdown 
menu. The Transformation Pipeline is calculated 
only on these cells. The selection depends on 
your experimental goal.

	 EXAMPLE: Choose CD45+. 

	� �Check that the merged file is now set in the 
Template File field in the Parameter Options 
section for the tSNE calculation. If not, click on the 
plot inserted in Step 3 of the Merging Data Files 
for Preparation of FlowSOM section, and choose 
Select Template From Selected Plot.

1	� Click Transformations on the Tools tab. Click the 
blue plus  and choose Pipeline. 

	� EXAMPLE: PBMC sample 1.fcs – PBMC sample 
4.fcs (4) Files is set as the Template File. 

	� �The Template File provides the raw data 
parameters associated with the file(s) selected for 
the FlowSOM analysis. 

	� EXAMPLE: For the 7C_human_kit_analysis_
template.fey layout and the associated example 
data files, the template file will automatically 
contain the data currently loaded in the layout. 

3	� Click the blue plus  at the top of the 
Transformations window on the right. Select 
Pre-Defined Algorithms and then FlowSOM.

4	� Click to expand the New FlowSOM node to reveal 
its six substeps.

5	� Click on New Scaling (A). Select the parameters 
under Parameter Options (B) that the 
Self-Organizing Map will use to calculate. 
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	� NOTE: Right-click within the box to Deselect All 
first and enter CD in the Filter: field to narrow 
down the list.

	� EXAMPLE: Select all the “CD” parameters 
(CD20, CD45, CD14, CD16, CD8, CD3, and 
CD4). The chosen parameters depend on the 
experimental goals.

6	� Select New Batch Self-Organizing Map (A). 
Choose the Parameter Options (B) defined in the 
previous substep, if they are not selected.

7	� (Optional) If you wish to change other options 
within any of the FlowSOM substeps, you may do 
so. Details on the settings are available in the FCS 
Express manual here. 

8	� (Optional) Add a downsampling step before the 
New Scaling substep in the Pipeline.

9	� Select New Parameter Removal (A). Then select 
the scaled parameters (defined in the previous 
substep), if they are not selected (B). This step 
prevents duplicate copies of these parameters 
from appearing in your plot axes.

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/pipeline_elements_2_2.htm?zoom_highlightsub=flowsom
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?pipeline_elements.htm
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Running the FlowSOM Algorithm 

1	� Drag and drop the New Pipeline transformation 
from the upper pane of the Transformations 
window to the Plate Heat Map plot inserted in 
Step 3 in the Merge Data Files for Preparation of 
tSNE Run section (note that plot title changes).

2	� Select New Pipeline (A) in the upper pane of 
the Transformations window. Click Execute 
Transformation Pipeline (B) under Run Options.

3	� On the Format tab, select Legend (A) and check 
the Visible box (B).

4	� Click on the X- and Y-axes to change them 
to Batch SOM Cluster Assignments and 
any parameter of your choice (e.g., CD16), 
respectively. Enter CD16 or any other text after 
clicking on the Y-axis to filter the list.

	� The red-green gradient in the legend displays the 
mean expression level of the Y-parameter for each 
node (the internal color of the cluster). The discrete 
color swatches 1–8 on the right side of the legend 
denote the metaclusters (the peripheral color of 
the cluster). 



12

Deconvolving/Ungrouping Individual Data Files

You can view the FlowSOM results of each component file after performing FlowSOM on a merged sample. 
You can also group component files from within the merged file for final analysis. In the next steps we 
automatically create gates on each component file of the merged files to facilitate deconvolution. If you only 
wish to view the results on the merged file, proceed to the next section, Interrogating Metacluster Phenotypes.

2	� On the Gating tab, select Well (A) and then click 
and drag your mouse to encompass all the wells 
on the Plate Heat Map that was created Step 3 in 
the Merge Data Files for Preparation of tSNE Run 
section (B). Enter auto-FlowSOM in the Create a 
new gate named field (C).

3	� Select the gate on which the FlowSOM was 
calculated (D). This was the gate specified in Step 
3 of the Choosing Variables and Defining the 
FlowSOM Settings section. 

	� EXAMPLE: Choose CD45+ from the Parent Gate 
dropdown menu (E). 

4	� Check the Create individual gates for each file 
identifier checkbox (E) and choose black from the 
Gate color dropdown menu (F). Click OK (G). 

5	� Click on the FlowSOM plot to select it. On the 
Gating tab, select Current Gate dropdown menu 
and then choose the first automatically created 
gate. This gate corresponds to the first original 
component data file in the virtual merged file. 

	� The plot is now regated to show only the events 
corresponding to the original data file. Repeat for 
the other component files (optional).

1	� On the Insert tab, select Heat Map, then Plate 
Heat Map. Click once on an empty spot on the 
layout to create the Plate Heat Map plot.

	 �NOTE: The plot title should contain Pipeline 
transformed. If it does not, click on the FlowSOM 
plot from the previous step prior to performing 
this step.

6	� (Optional) To view the results from the individual 
component files in separate plots side by side 
within the layout, select, copy, and paste the 
plot as many times as you have component files. 
Then, on the Gating tab, select the Current Gate 
dropdown menu and choose the automatically 
created gate that corresponds to the original 
component data file of interest. Repeat this 
on each new plot as needed for the other 
component files.

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?selecting_multiple_objects.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?copying_objects.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?pasting_objects.htm
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Interrogating Metacluster Phenotypes 

1	� Press Cmd[mac]-/Ctrl[PC]-D on your keyboard to 
duplicate the plot, and move it below or next to 
the existing plot.

2	� Click on the X-axis to change it to Consensus 
Clustering Assignments.

3	� On the Gating tab, select Well (A) and then click 
and drag your mouse cursor to encompass all 
the wells on your Plate Heat Map created in the 
previous step (B). Enter Metacluster in the Create 
a new gate named field (C). 

4	� From the Parent Gate dropdown menu (D) do one 
of the following:

	� a	� If you only want to interrogate metaclusters 
at the level of the merged file, then select the 
gate on which FlowSOM was calculated (CD45 
in the example).

	 b	� If you want to interrogate metaclusters at the 
level of the original component data files, 
select a gate with the prefix AutoFlowSOM that 
were created in Steps 1–4 in the Deconvolving/
Ungrouping Individual Data Files section. 
These gates correspond to one of your 
original component files. 

		�  EXAMPLE: Choose the AutoFlowSOM-
Automatic Classification Gate PBMC sample 
1.fcs gate.

5	� Check the Create individual gates for each file 
identifier checkbox (E). Then choose black from 
the Gate color dropdown menu (F). Click OK (G).

	� NOTE: If you choose to create the metacluster 
gates as children of an AutoFlowSOM gate that 
corresponds to one of the original component 
files, and would like to interrogate these 
metaclusters within the other component files, 
you may use the Clipboard to duplicate these 
gates and copy them as children of the other 
component file gates. This will enable the 
phenotypic metacluster analysis for each of the 
component files.

6	� Click Density and/or Color Dot on the Insert tab, 
then click once on a blank spot of the layout to 
insert a new plot.

7	� Change the parameters of this new plot to any of 
your choice (e.g., CD3 vs. CD20).

8	� Click Gate View on the Insert tab, and click once 
on your layout to insert the object. Right-click 
within the object and select Expand All to reveal 
the new gates within your existing hierarchy.

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?gates_and_the_clipboard.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?gates_and_the_clipboard.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?gates_and_the_clipboard.htm
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9	� Drag and drop the first metacluster gate using 
its black color block square to the Density and/
or Color Dot plot created in Step 6 to regate the 
plot(s). Repeat this step with the other metacluster 
gates to interrogate the other metaclusters. 
Alternatively, duplicate the existing plot(s) as 
needed, regating each time on a different 
metacluster gate. This allows you to view the 
results from multiple metaclusters simultaneously.

	 �We will now evaluate expression across the 
metaclusters using a Parameters Heat Map.

10	� On the Insert tab, select Heat Map and then 
Parameters Heat Map. Click once on an empty 
spot on the layout to create the Parameters Heat 
Map plot.

	� NOTE: The plot title will be amended with 
Pipeline transformed. If not, click on the FlowSOM 
plot from a previous step and try this step again.

11	� Expand the plot width of the Parameters 
Heat Map.

12	� Click Parameters To Display on the Format tab. 
Select the desired parameters under Parameter 
Options in the window.

13	� Choose Axes in the toolbar (A), then select 
X Axis (B), scroll down, and enter 90 in Angle 
(C). Expand the plot height to see the vertically 
oriented X-axis labels clearly (D).

14	� Drag and drop the merged filename from the 
Data List to the Parameters Heat Map (A). Click 
add the files to the plot as new overlays (B), 
then click OK (C).
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15	� Repeat the preceding step for each metacluster.

	 �NOTE: You may need to expand the height 
of the plot to see all of the metaclusters as 
horizontal Y-axis labels.

16	� Choose Overlays in the toolbar on the Format 
tab (A). Click in the list at the top and select all 
overlays in the list at the top (via Cmd[mac]-/
Ctrl[PC]-A) (B). Then select Median from the 
Statistic to show dropdown menu (C) and Gate 
for the Legend Text (D).

17	� Select the first overlay in the list at the top (A). 
Then select the first metacluster Metacluster: 
Cluster Assignment 1 from the Gate options (B).

18	� Repeat the preceding step for each overlay, 
so that overlay #2 is gated on the Metacluster: 
Cluster Assignment 2, #3 on Metacluster: Cluster 
Assignment 3, etc.

19	� Choose Legend in the dropdown menu and 
check the Visible box.

	� The plot will now resemble those shown below. 

20	�To adjust the logic by which colors are assigned 
(i.e., rows vs. columns options, pictured below), 
color levels (palettes), color scales, radius 
visibility for displaying additional statistics, and 
other options, see Specific Options, Color 
Levels, and Overlays formatting options on the 
Format tab.

https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?parameters_heat_map_specific_option.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?parameters_heat_map_color_level.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?parameters_heat_map_color_level.htm
https://fcsexpressdownloads.s3.amazonaws.com/manual/manual_MAC_RUO/index.html?parameters_heat_map_overlays.htm


Summary

Now that you know the basics of high-dimensional analysis in FCS Express, you can perform tSNE and 
FlowSOM analysis on mass cytometry data. For additional practice, there are additional tutorials on the De 
Novo Software website. For a more in-depth training on FCS Express, contact your Standard BioTools™ field 
applications specialist who will connect you to your De Novo Software FAS.
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